XenDesktop 7: Studio takes long time to launch and is slow

Summary:

XenDesktop 7.x Studio takes a long time to start and refresh views

Issue:

When utilising XenDesktop Studio on a server with no internet access (hopfully this is the case!), I noticed that it took a very long time to start Studio, view machine catalogs etc..

This is because the server is attempting to validate the publisher certificate in the background by going to the internet, unfortunately as you have no internet access Studio is waiting for the time-out to expire before continuing.

Resolution:

Simply disable the publisher check in Internet Explorer Advanced Settings.

Usually you would not do this on a client, but since the server is unable to get to an external server the security risk is minimal.

Implementation:

1) Open internet explorer

2) Click Settings > Internet Options

3) Click Advanced

4) Uncheck “Check for publisher’s certificate revocation”

XenDesktop7_StudioTakesLongTimeToLaunch

You can view the full KB article here:

http://support.citrix.com/article/CTX139325

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s